CIS 221 Lab 8 Configuring and Managing Shared Folders


Lab 8 Configuring and Managing Shared Folders 
This lab contains the following exercises and activities:

· Exercise 8-1: Sharing a Folder on the Network

· Exercise 8-2: Accessing Shared Folders

· Exercise 8-3: Monitoring Shared Folders

· Exercise 8-4: Sharing a Folder with Multiple Names

· Lab Review Questions
Scenario
You are an internal technical support agent at Contoso, Ltd. The Accounting division has a need to share financial documents. Currently, the accountants send e-mail messages with the files attached and store the files in their My Documents folders.

This causes several problems. First, there is no master document, so nobody ever knows where they can find the most recent version of a document. Second, sending the documents as e-mail attachments is inefficient.

You have been asked to set up shared folders to solve these problems.
After completing this lab, you will be able to:

· Share folder and set share permissions.

· Monitor shared folders with the Shared Folders snap-in.

· Configure files for offline use and manage synchronization.

· Share a folder with multiple share names and permission sets. 

Before You Begin
Establish your network connection using the following steps.

1. Log on as local Administrator.

2. From the Start menu right click on My Computer and select Properties

3. From the Computer Name tab click on Change.

4. In the Computer Name Change dialog box erase .local from the Domain box.

5. Click OK

6. In the Computer Name Chang dialog box in User name type Administrator and in the Password box type none.

7. Click OK

8. After a few seconds you will be welcomed to the Contoso domain click OK.

9. Click on the dialog box that tells you that you must restart your computer.

10. Click OK in the Systems Properties dialog box.

11. Click Yes in the Systems Setting Change dialog box, you computer will shut down and restart.

12. Log on as local administrator.

13. From the start menu select Control Panel
14. Select Security Center

15. Open the Windows Firewall and make sure that it is Off.

16. Close all windows.

This lab uses the variable xx to refer to your number so that your computer name is referred to as Computerxx and your student identity as Studentxx. You are asked to pair with another student in this lab. Your partner's number will be referred to as yy.
Exercise 8-1: Sharing a Folder on the Network

After discussing the needs of the accountants with the department head, you have decided to create two folders on a Microsoft Windows XP Professional workstation serving as file server for the domain.

The first shared folder is for general accounting data and should be available with Read and Write permissions to the Accountants group and the Full Control permission for the Domain Admins group.

The second folder should be available with the same permissions, but it should allow only one user to connect at a time. This will ensure that more than one person cannot modify the file simultaneously, which could lead to inconsistent versions of the file. This folder should also be set to automatically cache the file locally.

Sharing a Folder with the Create A Shared Folder Wizard

The following steps will create a shared folder using the Create A Shared Folder Wizard.

1. Log on with your local Administrator credentials (the password is P@sswOrd).

2. From the Start menu, right-click My Computer and then select Manage.

3. In the Computer Management console, in the console tree, under System Tools, expand Shared Folders, and then select Shares.

 Question 1: What shares currently exist?
4. From the Action menu select New File Share.

5. In the Create A Shared Folder Wizard, on the Welcome page, click Next.

6. On the Setup A Shared Folder page, in the Folder To Share text box, type     C:\Accounting Data.

7. In the Share Name text box, type Accounting Data.

8. In the Share Description text box, type Financial statements and year end projections. The correct entries are shown in the following figure.
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9. Click Next
10. In the Create A Shared Folder Wizard message box, click Yes to create the Accounting Data folder.

11. In the Shared Folder Permissions dialog box, select Customize Permission. 

Question 2: What four permissions settings are offered for the shared folder?

12. Click Custom.

13. In the Customize Permissions dialog box, click Remove and then click Add.

14. In the Select Users, Computers, Or Groups dialog box, in the Enter The Object Names To Select (Examples) text box, type Contoso\Accountants and then click Check Names.

15. In the Enter Network Password dialog box, in the User Name text box, type Administrator and in the Password text box, type none. Click OK.

16. In the Select Users, Computers Or Groups dialog box, Accountants appears. Click OK.

17. In the Customize Permissions Properties dialog box, in the Permissions For Accountants list box, select the Allow check box for the Change permission. 
18. Click Add.

19. In the Select Users, Computers, Or Groups dialog box, in the Enter The Object Names To Select (Examples) text box, type Domain Admins and then click Check Names. Domain Admins should appear. Click OK (the process may take a few seconds).

20. In the Customize Permissions Properties dialog box, in the Permissions For Domain Admins list box, select the Allow check box for the Full Control permission. Click OK.

21. In the Create A Shared Folder Wizard, click Next.
Question 3: What folder have you successfully shared and with which network users?
22. On the Completing The Create A Shared Folder Wizard page, click Finish.

23. Close the Computer Management console.

Sharing a Folder Manually 
The following steps will share a folder through the folder's Properties dialog box.

1. From the Start menu, select My Computer.

2. In the My Computer window, from the Tools menu, select Folder Options.

3. In the Folder Options dialog box, on the View tab, in the Advanced Settings list box, clear the Use Simple File Sharing check box, as shown in the following figure.
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4. . Click OK
5. In the My Computer window, double-click Local Disk (C:).

6. In the Local Disk (C:) window, from the File menu, point to New and then select Folder.

7. For the name of the folder, type Sales Projections and then press ENTER.

8. Right-click Sales Projections, and then select Properties.

9. In the Sales Projections Properties dialog box, on the Sharing tab, select Share This Folder.

10. In the User Limit section, select Allow This Number Of Users, and in the spin box, type 1.

11. Click Permissions.

12. In the Permissions for Sales Projections dialog box, click Remove and then click Add.
13. In the Select Users, Computers, Or Groups dialog box, in the Enter The Object Names To Select (Examples) text box, type Contoso\Accountants and then click Check Names.
14. In the Enter Network Password dialog box, in the User Name text box, type Administrator and in the Password text box, type none. Click OK.
15. In the Select Users, Computers Or Groups dialog box, Accountants (it may take a little while for accountants to appear) appears. 
16. Click OK.
17. In the Customize Permissions Properties dialog box, in the Permissions For Accountants list box, select the Allow check box for the Change permission.
18. Click Add.
19. In the Select Users, Computers, Or Groups dialog box, in the Enter The Object Names To Select (Examples) text box, type Domain Admins and then click Check Names. Domain Admins should appear. Click OK (the process may take a few seconds).
20. In the Customize Permissions Properties dialog box, in the Permissions For Domain Admins list box, select the Allow check box for the Full Control permission. Click OK.

21. In the Sales Projections Properties dialog box in the Share tab, click Caching.

22. In the Caching Settings dialog box, in the Setting drop-down list, select Automatic Caching Of Documents. 
Question 4: Fill in the chart with the explanation for each setting in the drop down box for settings.

	Automatic Caching of all Documents
	

	Automatic caching of programs and documents
	

	Manual caching of documents
	


23. Click OK.

24. In the Sales Projections Properties dialog box, click OK.

25. Close all windows and Log off.
Exercise 8-2: Accessing Shared Folders

Now that you have created the shared folders, you need to make sure that the accountants know how to access them.

Accessing Shared Folders Through My Network Places

The following steps will allow you to access a shared folder using My Network Places.
1. Log on to Contoso as Mzwilling (the password is P@sswOrd).

Important Wait until your partner has completed the previous step before continuing.
2. From the Start menu, point to All Programs, Accessories, and then select Windows Explorer.

3. In Windows Explorer, in the tree view on the left, expand My Network Places, Entire Network, Microsoft Windows Network, Contoso, Computeryy, and then select Accounting Data, as shown in the following figure from Computer07 (looking at a share on Computer08).
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4. From the File menu, point to New and then select Text Document.

5. For the name of the document, type Balance Sheet and then press ENTER.
Wait until your partner has completed the above steps.

6. Log off and log back on with your Contoso student account.

7. Open Windows Explorer
8. In Windows Explorer, in the tree view on the left, expand My Network Places, Entire Network, Microsoft Windows Network, Contoso, Computeryy, Accounting Data folder.
Question 5: What occurs when you try to access the shared folder Accounting Data on your partner's computer?

9. Click OK.

10. In Windows Explorer, browse to C:\Accounting Data.

Question 6: Why are you able to access the shared folder Accounting Data on your computer, but you are not able to access the same folder on your partner's computer, when the share and NTFS permissions are identical?

11. Log off.
Mapping a Drive to a Network Folder

To simplify accessing the Sales Projections folder, you decide to have the accountants map it to a drive. This will allow them to treat the folder as a separate drive. 
1. Log on to Contoso as MZwilling
2. Open Windows Explorer.

3. From the Tools menu, select Map Network Drive.

4. In the Map Network Drive dialog box, in the Drive drop-down list, select M:.

5. In the Folder text box, type \\Computeryy\Sales Projections. (You can also browse to the location, which eliminates the possibility of typographical errors.)

6. Ensure that the Reconnect At Logon check box is selected. 
7. Click Finish.

8. In the Sales Projections On `Computeryy' (M:) window, from the File menu, point to New and select Text Document.

9. For the name of the document, type Projections 2010 — 2015 and then press ENTER.

10. From the View menu, point to Explorer Bar and then select Folders.

Important Wait until your partner has completed the previous step before continuing.

11. In the tree view, expand My Network Places, Entire Network, Microsoft Windows Network, Contoso, Computerxx, and then select Sales Projections. 
Question 7: Summarize what the message box states.
Question 8: The Sales Projections folder that we just tried to access is stored locally. because share permissions apply only to resources accessed over the network, why were we unable to access the Sales Projections folder?

12. In the message box, click OK.

13. Close all open windows.
Accessing Shared Folders Using the Run Dialog Box

A quick and easy way to access a shared resource that you know the path of is through the Run dialog box.

1. From the Start menu, select Run.

2. In the Run dialog box, in the Open text box, type \\Computeryy\Sales Projections and then press ENTER.

3. Close the Sales Projections On Computeryy window.

4. Open a Run dialog box. In the Open text box, type \\Computeryy and then press ENTER. A Computeryy window with all the resources available to MZwilling on Computeryy appears. 
Question 9: List the types and names of resources available to MZwilling. 

5. Leave this window open for the next exercise.
Exercise 8-3: Monitoring Shared Folders

Now that you have successfully set up shared folders and have configured access to them, you want to be able to see how they are being used. This will allow you to tweak the settings if needed and to decide if it is a good model to use in other divisions of Contoso.

1. In the Computeryy window, double-click Sales Projections.

2. In the Sales Projections window, double-click Projections 2010 - 2015. 

Important Wait until your partner has completed the previous step before continuing.

3. From the Start menu, select Control Panel.

4. Open Administrative Tools.

5. Right click on Computer Management and select Run as
6. Select The following user.
7. Enter the password (P@ssw0rd) for the local administrator (should automatically come up in the User name box) and click OK
8. In the Computer Management console, in the console tree, under System tools, expand Shared Folders, and then select Sessions.

Question 10: How many open files are there in MZwilling's current session?

9. In the console tree, select Open Files.

Question 11: What folder is the open file located in?

Important Wait until your partner has answered the previous step before continuing.

10. Close all open windows.
Exercise 8-4 Sharing a Folder with Multiple Names

The accounting team has finalized the documents in the Sales Projections folder. There is no longer a need for the Accountants group to change the files.

You need to remove the change permission for the Accountants group. Also, to increase security on the folder, and because it will need to be accessed only by the Domain Admins group for administrative reasons, you need to create another share name for the folder that is hidden.

1. Log on with your local Administrator account.

2. From the Start menu, select My Computer.

3. In the My Computer window, double-click the Local Disk (C:) drive.

4. In the Local Disk (C:) drive, right-click Sales Projections and then select Properties.

5. In the Sales Projections Properties dialog box, on the Sharing tab, click New Share.

6. In the New Share dialog box, in the Share Name text box, type Sales Projections Admin$ and then click OK.

7. In the Sales Projections Properties dialog box, in the Share Name list box, ensure that Sales Projections Admin$ is selected, and then click Permissions.

8. In the Permissions For Sales Projections Admin$ dialog box, click Remove.

9. Click Add.
10. In the Select Users, Computers, Or Groups dialog box, in the Enter The Object Names To Select (Examples) text box, type Contoso\Domain Admins and then click Check Names. Domain Admins should appear. 
11. Click OK (the process may take a few seconds).
12. The Permissions For Sales Projections Admin$ dialog box should Be configured as in the following figure. 
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13. Click OK.
14. In the Sales Projections Properties dialog box, in the Share Name drop-down list, select Sales Projections and then click Permissions.
15. In the Permissions For Sales Projections dialog box, select Domain Admins and then click Remove.

16. Clear the Allow check box for the Change permission for the Accountants group so that the accounts have the Allow check box selected only for the Read permission. 
17. Click OK.

18. In the Sales Projections Properties dialog box, select Maximum Allowed and then click OK.
19. Close all windows

20. Turn off computer.

Lab Review Questions
1. How can you designate a share as an administrative share, which will cause it to be hidden?

2. You create a shared folder and allow only Domain Admins access to it. However, you find that you can access the folder on the file server when you log on as a Domain User. Why can you access the folder?

3. You work for a software company that sells tax software. They have been selling the same DOS-based application for 15 years because their clientele is used to it and can use it very efficiently. The software was designed before networking was available, and you need to store the data files on a file server rather than the local machine. However, the program will work only if the data designated by the software is stored on the root of a drive. How can you use the file server and satisfy the software's requirement that it be able to store data on the root of a drive?
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